WordPress 4.3 is here along with an update to WishList Member

WishList Member

We recently posted some information about how WishList Member is affected by WordPress version 4.3.

As it turns out, there are more changes in WordPress 4.3 that affect WishList Member than we originally expected. One of these WordPress 4.3 changes is quite significant to anyone running WishList Member and it has to do with adding new users to a WordPress site.

Without getting too technical, WordPress 4.3 returns a different response when adding a new user than previous versions of WordPress. This means that WishList Member will no longer allow new users to be added to a site that is running WordPress 4.3, which results in registrations not being successful.

But do not worry because we have already created a fix for the problem for all WishList Member users. How you apply this fix will depend on when you purchased a WishList Member license or renewal, as that will determine which version of WishList Member you can use. Our customers fall into two primary categories.

Category 1: Customers with access to WishList Member 2.9.

This category includes customers who purchased WishList Member after version 2.9 was released. It also includes customers that had active support and updates when version 2.9 was released.

Customers who have recently purchased an optional renewal fall into this category as well.

WishList Member 2.9 includes all of our latest features and now includes the bug fixes for WordPress 4.3.

If you fall into this category you can click here to skip down to the instructions on how to update to the latest release of WishList Member 2.9.

Category 2: Customers with access to WishList Member version 2.8 or lower.

This category includes customers who purchased WishList Member in the past and did not purchase an optional renewal plan after their included support and software updates expired.

Customers in this category may be running a variety of previously released versions of WishList Member (2.8, 2.7, 2.6, etc.).

How you apply the fix to your site will depend on if you have access to WishList Member 2.9 or 2.8.

If you are unclear of which version you have access to, it’s very simple to find out.

The dashboard of your installation of WishList Member will indicate what version you are running.

WP43-01-WLM-Version-Dashboard

Login to your WordPress site. Click on the WishList Member installation. On the dashboard you’ll find the version of WishList Member.

Instructions for updating WishList Member version 2.9:

If you’re currently running WishList Member 2.9 the update can be applied with a simple one-click upgrade from the WishList Member dashboard.

Once a new version is released it should show up automatically in the WishList Member dashboard. However, it can take up to 24 hours to be displayed on some sites.

You should see an option for a one-click upgrade.

WP43-02-WLM-Dashboard-One-Click

If you do not see the option for an upgrade, you can manually click on the link labeled “Check for Updates”.

WP43-03-WLM-Version-Dashboard-Check

* It is important to note, there are multiple ways to configure a server that runs WordPress. In many cases, the install will happen automatically. However, you may be asked to provide the FTP password for your website in order for this to complete. It will depend on how your hosting company has configured your server.

(As always, we recommend doing a full backup of your site before installing any updates).

Once you have updated your site, you should be running WishList Member 2.90.2860

WP43-04-WLM-Latest-Version

In some cases the plugin may not be automatically reactivated after the update. In this case, you simply need to go to the plugins section of WordPress. Scroll through the list of plugins and find WishList Member. Click on the button to activate the plugin.

WP43-05-Activate-Plugin

Instructions for updating WishList Member version 2.8 or lower:

The latest version of WishList Member 2.8 has been updated and now includes the necessary bug fixes for WordPress 4.3.

All versions of WishList Member prior to 2.8 are more than four years old and have reached end of life for updates. Consequently, they will not be updated with the fix. However, we recognize this problem with WordPress 4.3 is significant. So, we’ve given all customers with earlier versions of WishList Member access to version 2.8.

Please note that this update does not include an additional year of support or software updates. It simply provides access to WishList Member 2.8

If you would like to upgrade to the latest version of WishList Member 2.9 and get an additional year of support and updates, you can click on the Upgrade button in the WishList Member dashboard. This will bring you to the page that lists the features of version 2.9 and give an option to purchase the renewal for support and updates.

We recognize that many customers will not want to purchase a renewal to get additional support and all the latest features of WishList Member 2.9. In this case, it is simple to update your site to the version of 2.8 that includes the latest bug fixes.

Before starting this process we highly recommend making a backup of your site. This is standard practice before installing any update in WordPress.

Login to your install of WordPress and navigate to the WishList Member dashboard.

You should see an indication that you are running version 2.80 or earlier.

WP43-06-Update-Plugin-WLM28-Dashboard

After clicking the link for “Plugins” you should see the Plugins section of WordPress.

WP43-07-Update-Plugin-WLM28

This screen will indicate that a newer version of 2.9 is available. However, if you click on the “update now” option it will update your site to the latest version of 2.8 that includes the bug fixes for WordPress 4.3.

After updating you should see the screen change with a message that says “Updated!” with a green check in front of it.

WP43-08-Update-Plugin-WLM28-Success

* As mentioned earlier, it is important to note there are multiple ways to configure a server that runs WordPress. In many cases, the install will happen automatically. However, you may be asked to provide the FTP password for your website in order for this to complete. It will depend on how your hosting company has configured your server.

Once you have applied the update, you will still see that there is a newer version of 2.9 available in the WishList Member dashboard. This is OK. You simply need to verify that you are running version 2.80.2850.

WP43-09-Update-WLM-28-Dashboard-OK

Please note that WordPress 4.3 is currently not an automatic update at the time of this blog post being published. This means that you may not be running WordPress 4.3 yet. If you’re not running version 4.3 of WordPress this update may not be an immediate priority.

If you’re running an older version of WishList Member and do not want to apply an update then it is important that you do not upgrade your site to WordPress 4.3. If your site is upgraded to WordPress 4.3 then the update of WishList Member is necessary in order for the site to function properly.

Comments are closed.